Publishing Update Issue: Multiple deployments

I’m trying to make a minor edit to our carrier claim flow in Airkit and running into an issue. When trying to publish, it states I cannot publish for apps with multiple deployments. I found an HC article, but it’s not making sense to me… Profiles and Deployment Settings When I try to map our 3 deployments to the branch it’s pushing me in a loop so I must be doing something wrong. How would I resolve this? Thanks!

Hi @kadan9! Great question and also appreciate the feedback on the doc. We’ll look to include cases such as yours in case other developers run into the same issue.

For your scenario, it looks like you have multiple deployments for your app so in order to manage your deployments, you’ll need to publish and manage your branches from the console.

Lets say for example, you wanted to make a change to a DEV deployment.

First i would go to https://console.airkit.com and locate your app and click the ellipses next to the app name

Here you’l find two options: Manage Branches and Deployments.

If you 've made all your changes that you needed and want to deploy, you can select the branch you want to deploy, and duplicate it. It is good practice to name the branch something meaningful to keep track.

To do this: Manage Branches > Select Branch > Duplicate Branch


Make sure the branch is locked.

After you’ve duplicated the branch, you need to update your deployment to use the branch.

Go back to Console > Ellipses > Deployments and select the deployment you’d like to update

You’ll see the locked branch you created and you can then deploy.

I hope that helps!

Hi Ismaen,

Thank you for getting back to me so quickly. I created my three branches, but I keep running into various issues.

  1. When I try to map my branches to the deployments, it states I’m in an outdated version and to use the CXR 17.14 Console.
  2. When I follow the steps to go to the update, one deployment doesn’t show any branches, while the other two branches shoot back an error that something is already in use. I’m pretty certain the three branches I created aren’t being used by anything else.
  3. After a while, I get stuck in a loop of being asked to toggle to the CXR 17.14 Console.
    Do you know what I’m doing wrong? I have attached a GIF of me following the steps and the issues I ran into.

Thanks!

airkit.gif

@kadan9 Kaitlyn, is this for the Merchant Claim Form application? It looks like you were able to successfully upgrade to version 18.0 Can you confirm (please email jkepp@airkit.com)? Thank you.

Hi @kadan9! I found the issue why this is happening. So essentially you currently have a 17.14 branch that is deployed and the branch that is being deployed is v18.0. So one of the buttons is actually redirecting you to the wrong version of studio (only the latest) and is also providing a warning message to go back to v17.14 when we can actually dismiss it and continue on with the deployment.

Check out this loom video as i walk through the steps here. let me know if this helps!

1 Like

Thanks for the loom video! The workaround was successful for one deployment, but the other 2 deployments are showing the error that it’s already in use Loom | Free Screen & Video Recording Software | Loom

at 1:43 in your video, you publish the QA deployment but leave the profile as “Development” which is why you get the “Resource is in use” error. can you try to change that to QA?

Also can you do the same with your PROD deployment as well. Let me know if that resolves the issue!

Thank you, Ismane,

That worked! Unfortunately, I do not see my edits published :sweat_smile: Do you have a help center article that you could point me to?

When I look at my branches, it shows me the new card I want to add, but when I navigate to our live link for the form, I do not see the card. Another thing I noticed is that when I open the branches and click preview, I do not see this card there either. I attached a loom here.

I look forward to hearing back from you!

All the best,
Kait

Ah this seems like a configuration on the web flow itself. There’s a setting called “initial web page” that you need to set to correspond with the web page you’d like for the first page to navigate to.

You can see this at Web Flows builder > click on the Collect Merchant Data Web Flow > look at the bottom right hand corner and see Initial Web Page

Because this is a change to the app, you’ll have to modify an unlocked branch, then save, then duplicate it and lock the branch and redeploy, essentially re-doing the steps you did to deploy.

Thank you so much Ismaen. Everything is live and working now!

Happy New Year,
Kait

1 Like